Microsoft has confirmed final resolution (see below) so we are marking this incident as resolved as well.
"After a period of extended monitoring, we’ve confirmed through customer reports and service health telemetry that the issue is resolved."
Posted Nov 26, 2024 - 12:19 PST
Update
Microsoft has posted the update below, and we also see error rates returned to normal levels. We will continue to monitor both our systems and Microsoft's status pages until they mark it as fully resolved.
"From monitoring service telemetry, most users should now experience relief. We’ve completed our optimizations and we're continuing our period of extended monitoring to ensure the availability remains stable."
Posted Nov 26, 2024 - 06:02 PST
Update
Below is the latest update from Microsoft:
"The service is continuing to incrementally recover. We're forecasting that impact will be fully remediated by Tuesday, November 26, 2024, at 3:00 AM UTC, though we're closely monitoring our progress and will provide an updated timeline should the estimate change."
Posted Nov 25, 2024 - 18:09 PST
Update
Microsoft is reporting a partial recovery. Their most recent update is below:
"We’ve completed additional actions and are seeing some recovery. We’re continuing to monitor the service while we complete other workstreams intended to fully resolve the issue. Details can be found in the admin center under MO941162."
Posted Nov 25, 2024 - 13:34 PST
Update
Microsoft is still working on resolving this incident on their end. Their most recent update is below:
"We’re facing delays in our recovery efforts and are taking immediate action to address them. We understand the significant impact of this event to your businesses and are working to provide relief as soon as possible. More details can be found in the admin center under MO941162."
Posted Nov 25, 2024 - 12:48 PST
Monitoring
Microsoft has confirmed a severe degradation of their Outlook and Team services starting around 2:00 AM Pacific Time. This is impacting Nylas services calling their APIs for Email and Calendaring, resulting in an elevated number of 504 Gateway Timeout errors in our API responses, as well as elevated latencies. We are monitoring their progress closely and will post updates here as we receive them.
We apologize for the inconvenience and appreciate your patience. If you have any questions or concerns, please contact our support team (support@nylas.com).
Posted Nov 25, 2024 - 03:00 PST
This incident affected: 3rd Party Providers (Microsoft 365, Outlook.com).