This message serves as notification that the following updates have been made to the Nylas Subprocessors page.
The following subprocessors are being added: Inkeep.
The following subprocessors are being removed: Datasiv, PartnerPortal, Salesloft.
You can find the details regarding what data is being processed by each subprocessor, as well as the applicable components, locations, and entities on the Nylas Subprocessor page at https://www.nylas.com/security/subprocessors/
If you have any questions or concerns about the new subprocessor additions or removals, please contact our Security Team at security@nylas.com.
Posted Jul 21, 2025 - 12:45 PDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 21, 2025 - 12:45 PDT
Scheduled
This message serves as notification that we are making changes to Nylas' Subprocessors page today
Posted Jul 21, 2025 - 12:44 PDT
This scheduled maintenance affected: Subprocessors (* Subprocessor Change Notification).