EU - API v2 - Temporary Service Disruption for a Subset of Accounts

Incident Report for Nylas

Resolved

The restoration process for impacted accounts in the EU region has been fully completed, and system monitoring confirms that all services are operating normally.

For affected accounts, there may be delayed webhooks related to messages received while those accounts were offline. These are expected to be delivered shortly as backlogged data is processed.

Thank you for your patience and understanding throughout this incident.
Posted Jul 18, 2025 - 13:07 PDT

Monitoring

The restoration process for impacted accounts in the EU region has been successfully completed (100%). All services should now be functioning normally.

Our team is closely monitoring the system to ensure continued stability. If you experience any lingering issues, please don’t hesitate to contact our support team.

Thank you for your patience and understanding throughout this process.
Posted Jul 18, 2025 - 11:59 PDT

Update

We are continuing restoration efforts for a subset of accounts impacted by the earlier database failure. Restoration of the remaining ~7% of total EU user accounts is currently 70% complete.

Impacted accounts may continue to experience:
• No data synchronization
• Undelivered webhooks
• Failed API requests

Our team remains fully focused on completing the process as quickly and safely as possible. We’ll continue to share updates as we reach key restoration milestones. Thank you for your continued patience and understanding.
Posted Jul 18, 2025 - 10:00 PDT

Update

We are continuing restoration efforts for a subset of accounts impacted by the earlier database failure. Restoration of the remaining ~7% of total EU user accounts is currently 56% complete.

Impacted accounts may continue to experience:
• No data synchronization
• Undelivered webhooks
• Failed API requests

Our team remains fully focused on completing the process as quickly and safely as possible. We’ll continue to share updates as we reach key restoration milestones. Thank you for your continued patience and understanding.
Posted Jul 18, 2025 - 08:22 PDT

Update

We are continuing restoration efforts for a subset of accounts impacted by the earlier database failure. Restoration of the remaining ~7% of total EU user accounts is currently 46% complete.

Impacted accounts may continue to experience:
• No data synchronization
• Undelivered webhooks
• Failed API requests

Our team remains fully focused on completing the process as quickly and safely as possible. We’ll continue to share updates as we reach key restoration milestones. Thank you for your continued patience and understanding.
Posted Jul 18, 2025 - 07:24 PDT

Update

We are continuing restoration efforts for a subset of accounts impacted by the earlier database failure. Restoration of the remaining ~7% of total EU user accounts is currently 22% complete.

Impacted accounts may continue to experience:
• No data synchronization
• Undelivered webhooks
• Failed API requests

Our team remains fully focused on completing the process as quickly and safely as possible. We’ll continue to share updates as we reach key restoration milestones. Thank you for your continued patience and understanding.
Posted Jul 18, 2025 - 05:29 PDT

Update

We encountered an issue during the data restoration process for a subset of accounts in the EU region, which caused an unexpected delay.

The issue has been addressed, and restoration efforts are now progressing steadily again. Our team remains fully focused on completing the process as quickly and safely as possible.

Impacted accounts may continue to experience:
• No data synchronization
• Undelivered webhooks
• Failed API requests

We’ll continue to share updates as we reach key restoration milestones. Thank you for your patience and understanding.
Posted Jul 18, 2025 - 04:13 PDT

Update

We’ve reached 50% completion in the data restoration process for impacted accounts in the EU region.
As a reminder, affected accounts may continue to experience:

• No data synchronization
• Undelivered webhooks
• Failed API requests

Our team is actively working to complete the restoration as quickly and safely as possible.

The next update will be posted once we reach 100% completion.

Thank you for your continued patience and understanding.
Posted Jul 18, 2025 - 01:12 PDT

Update

We are continuing the restoration process for a subset of accounts affected in the EU region.

At this time, approximately 15% of the affected data has been successfully restored. Impacted accounts may still experience issues with data sync, webhook delivery, and API calls during this time.

Our next update will be posted once we reach 50% restoration progress.

Thank you for your continued patience.
Posted Jul 17, 2025 - 22:20 PDT

Identified

We are currently addressing an issue impacting a limited number of accounts in the EU region following a cluster migration.
Some accounts are temporarily unavailable and are experiencing:

• No data synchronization
• Undelivered webhooks
• Failed API requests

We have identified the root cause and are actively working to restore the affected accounts. The restoration process is underway and is expected to take approximately 3–4 hours.

We will continue to share updates as the work progresses. We appreciate your patience and understanding.
Posted Jul 17, 2025 - 21:22 PDT
This incident affected: Nylas Application Services (API, Sync Engine, Sync Status, Webhooks).