[US] Elevated rate of 500 errors at '/messages' endpoint.
Incident Report for Nylas
Resolved
This incident has been resolved.
Posted Jun 21, 2024 - 11:12 PDT
Update
We are seeing errors and timeouts back to normal levels. We will be monitoring for the next 30 minutes to ensure things remain stable.
Posted Jun 21, 2024 - 10:35 PDT
Monitoring
Mitigation measures are done and we are seeing improvements in error rate as well as less timeouts.
Posted Jun 21, 2024 - 09:42 PDT
Update
We are adding mitigation measures, and deployment is in progress.
Posted Jun 21, 2024 - 08:35 PDT
Update
We are still in the process of identifying a fix for this issue
Posted Jun 21, 2024 - 07:38 PDT
Identified
We have identified an issue in our infrastructure causing an elevated rate of 500 errors at messages endpoint and are working on a fix.
Posted Jun 21, 2024 - 07:05 PDT
Update
We have narrowed the scope of the impact to just the '/messages' endpoint. We continue to investigate the root cause.
Posted Jun 21, 2024 - 06:12 PDT
Update
We are continuing to investigate this issue.
Posted Jun 21, 2024 - 05:52 PDT
Investigating
We're experiencing an elevated level of 500 errors across multiple endpoints and are investigating the issue.
Posted Jun 21, 2024 - 05:13 PDT
This incident affected: Nylas Application Services (API).